PDF Extractor - извлекаем информацию из PDF с помощью Poppler

Публикация № 1241161

Разработка - Инструментарий разработчика - Прочие инструменты разработчика

PDF poppler извлечь текст картинки разбить объединить

«Класс» - обёртка для упрощения использования возможностей Poppler из 1С. Позволяет просто извлекать информацию из PDF-файлов в виде изображений и текста.

Мой велосипед для извлечения информации из PDF.

Изначально было необходимо находить и сохранять содержание книги в виде картинки для сайта из PDF-файлов, предоставляемых издательством, но применений можно найти массу.

По сути представляет из себя обёртку для более удобного использования библиотеки Poppler, поэтому последний должен быть установлен на компьютере. Poppler можно прописать в PATH, либо указывать путь к библиотеке непосредственно в обработке.

Возможности:

  • Извлечение страниц файла в виде изображений (настраивается качество, номера страниц, цветность, форма)
  • Извлечение страниц файла в виде текста
  • Извлечение отдельных изображения, содержащихся в PDF-документе
  • Разбиение (разделение) одного файла на несколько
  • Объединение нескольких файлов в один

Примеры использования:

1. Сохраняем каждую страницу файла, как отдельное изображение
PDF_Extractor = Обработки.PDF_Extractor.Создать(); // Если встроили обработку в конфигурацию
PDF_Extractor.КаталогPoppler = ""; // Можно не указывать, если poppler прописан в PATH
Изображения = PDF_Extractor.ФайлВИзображения("D:\my_file.pdf");

Для Каждого Изображение ИЗ Изображения Цикл
   Картинка = Новый Картинка(Изображение.ДвоичныеДанные);
   // Дальнейшая работа с изображением   
КонецЦикла;
2. Извлечение текста
PDF_Extractor = Обработки.PDF_Extractor.Создать();
Страницы = PDF_Extractor.ФайлВТекст("D:\my_file.pdf");

Для Каждого Страница ИЗ Страницы Цикл
    Если 0 < Найти(Страница.Текст, "что-то") Тогда
        // Обработка текста, поиск и т.п.
    КонецЕсли;
КонецЦикла;
3. Извлечение встроенных картинок
PDF_Extractor = Обработки.PDF_Extractor.Создать();
Изображения = PDF_Extractor.ИзображенияИзФайла("D:\my_file.pdf");

Для Каждого Изображение ИЗ Изображения Цикл
    НомерСтраницы = Изображение.НомерСтраницы;    // Возможно, ищем картинку
    НомерКартинки = Изображение.НомерИзображения; // на конкретной странице
    Расширение = Изображение.Расширение;
    Картинка = Новый Картинка(Изображение.ДвоичныеДанные);
    // Дальнейшая работа с изображением
КонецЦикла;
4. Разбиваем один файл на несколько
PDF_Extractor = Обработки.PDF_Extractor.Создать();
Файлы = PDF_Extractor.РазбитьФайл("D:\my_file.pdf", "D:\Каталог"); // Каталог можно не указывать

Для Каждого Файл ИЗ Файлы Цикл
    Сообщить("Создан файл: " + Файл.ПолноеИмя);
КонецЦикла;

5. Склеиваем несколько файлов в один

ФайлыДляОбъединения = Новый Массив();
ФайлыДляОбъединения.Добавить("D:\small_file_1.pdf");
ФайлыДляОбъединения.Добавить("D:\small_file_2.pdf");
ФайлыДляОбъединения.Добавить("D:\small_file_3.pdf");

PDF_Extractor = Обработки.PDF_Extractor.Создать();
Файл = PDF_Extractor.ОбъединитьНесколькоФайлов(ФайлыДляОбъединения, "D:\big_file.pdf");
ОтправитьФайл("mail@example.com", Файл); // Или любая другая обработка полученного файла
6. Получение служебной информации о файле
Сообщить(PDF_Extractor.СтрокаИнформацииОФайле("D:\my_file.pdf"));
// или так
Информация = PDF_Extractor.ИнформацияОФайле("D:\my_file.pdf"));
Для Каждого Поле ИЗ Информация Цикл
    Сообщить(Поле.Ключ + " - " + Поле.Значение);
КонецЦикла;

Ложка дёгтя:

Так как это всё-таки обёртка над библиотекой, то есть некоторая неиформативность в сообщениях об ошибках. Наверно, можно сделать вывод ошибок более понятным, но я, если честно, не очень старался в этой части.

Все методы в случае ошибки возвращают Неопределено. Если это произошло, вызываем метод ПоследняяОшибка() и получаем примерно следующее:

Сообщить(ПоследняяОшибка());

// Не удалось сохранить страницу файла
// pdftoppm "D:\383251.pdf" -r 200 -f 12 -l 12 -jpeg > "C:\Windows\Temp\v8_2F17_be.jpeg"

Используя команду, на которой вывалилась ошибка можно определить, что пошло не так.

Тестировалось в следующих условиях:
  • ОС Windows 10 x64, релизы платформы 8.2.19.116 и 8.3.16.1148
  • ОС Ubuntu 18.04 x64, релиз платформы 8.3.15.1565

Похожие разработки:

P.S.1 Корректировка ошибок и предложения по улучшению приветствуются.
P.S.2 Бинарники для Windows брал здесь.

Скачать файлы

Наименование Файл Версия Размер
PDF Extractor - извлекаем информацию из PDF с помощью Poppler:

.epf 15,28Kb
25.05.20
4
.epf 20200529 15,28Kb 4

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. утюгчеловек 12 26.05.20 12:51 Сейчас в теме
Почему бы не встроить бинарники поплера в обработку в качестве макетов, сохранять во временную папку и запускать оттуда, избавляя пользователя необходимости устанавливать попплер отдельно?
Это не секьюрно, но раз решение все равно нацелено на личное использование - можеть оказаться удобно, нет?
2. salexdv 1612 26.05.20 13:26 Сейчас в теме
(1) Poppler может обновляться, и каждый раз при этом обновлять обработку не очень хочется, да и занимают эти бинарники довольно много места. Кроме того решение, вроде как, кроссплатформенное.
Если бы это была часть распространяемого решения, тогда да, ваш вариант был бы очень кстати.
3. Nio 59 29.05.20 09:00 Сейчас в теме
Подскажите пожалуйста а распознать текст на картинке в фале pdf может?
Сканируют на сканеры документ и присылают в pdf.
4. salexdv 1612 29.05.20 09:14 Сейчас в теме
(3) К сожалению, нет. Если PDF сделан, как обычный документ, тогда текст извлекается, а со сканера - это чисто картинка.
5. Nio 59 29.05.20 13:03 Сейчас в теме
(4) Эх чуда не произошло. Спасибо.
6. salexdv 1612 29.05.20 14:46 Сейчас в теме
(5) Вы можете сохранить каждую страницу, как отдельную картинку, а потом попробовать что-то вроде этого.
7. Nio 59 29.05.20 20:34 Сейчас в теме
(6)Да я видел. Застрял на получение токена. Токен вроде есть а не работает.
Оставьте свое сообщение

См. также

Публикаций не найдено

Попробуйте расширить область поиска, проверьте поисковый запрос и повторите попытку.

Или закажите индивидуальную разработку вашего решения.

Создать заказ на разработку